Fixing Bittorrent clients crashing on Ubuntu


There are many Bittorrent client in Linux and, under Ubuntu (and this is surely true for other Linux distributions too), most of them depend on a library called libtorrent.

Under Ubuntu 12.04 LTS, libtorrent is buggy and causes Bittorrent clients to crash on a regular basis. The solution is, of course, to upgrade libtorrent from 0.15 to its latest version 0.16. The way to do that is to add the ppa:surfernsk/internet-software PPA and upgrade the whole system:

sudo add-apt-repository ppa:surfernsk/internet-software

sudo apt-get update

sudo apt-get upgrade

Doing that upgrades python-libtorrent to 0.16 and installs libtorrent-rasterbar7. Removing libtorrent-rasterbar6 (which is not needed anymore) is simply a

sudo aptitude remove libtorrent-rasterbar6

Since doing that, Deluge, the Bittorrent client I use, hasn’t crashed at all. Life is cool.

(Solution obtained in the Deluge forum)

Speak Your Mind